Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1
  • 2

TOPIC: XOT objects not displaying in Safari

XOT objects not displaying in Safari 3 years 8 months ago #2172

  • David Perkins de Oliveira
  • David Perkins de Oliveira's Avatar
  • Offline
  • Junior Boarder
  • Posts: 26
We have just noticed that Xerte objects we have created no longer display in Safari. The Xerte frame sometimes appears momentarily and then goes blank. If the title page has a background image, only this is shown. This happens with both embedded (iframe) Xerte objects or using the hyperlink. Xerte Bootstrap objects seem to be displaying fine, however.
Has anyone else noticed any similar problem with Safari recently?

Interestingly, some examples from other institutions don't work either:
https://xerte.lncd.lincoln.ac.uk/play.php?template_id=1957
http://www.nottingham.ac.uk/~cczjrt/sheppard/

While others do:
http://xerteonline.uws.ac.uk/play.php?template_id=267
http://194.7.157.205/moodle/xertetoolkits/play.php?template_id=12507

David
Last Edit: 3 years 8 months ago by David Perkins de Oliveira. Reason: Wrong topic (no tip on topic images)
The administrator has disabled public write access.

XOT objects not displaying in Safari 3 years 8 months ago #2174

  • Ron Mitchell
  • Ron Mitchell's Avatar
  • Offline
  • Administrator
  • Posts: 416
  • Thank you received: 101
Hi
I'm guessing that your installation is using https rather than just http?
I can't be 100% about both the non-working links you've posted but there is a known issue that has arisen recently due to external changes on the MathJax CDN which will seem intermittent due to the variation in use of installations via http and https and exported projects where https is used. You can read more about that change here: www.mathjax.org/changes-to-the-mathjax-cdn/

There are 3 files in the Xerte install which point to the now broken source but I think this is only likely to materialise when https is in use. It's also compounded by installations that aren't kept up-to-date which is a common problem. Do you have access to your installation files?

HTH
Ron
e-learning & m-learning consultant
mitchellmedia.co.uk
xerteacademy.com
learningapps.co.uk
The administrator has disabled public write access.

XOT objects not displaying in Safari 3 years 8 months ago #2175

  • David Perkins de Oliveira
  • David Perkins de Oliveira's Avatar
  • Offline
  • Junior Boarder
  • Posts: 26
Thanks for the quick reply, Ron. Yes, we appear to use https but this is a bit beyond my technical capabilities, so I'm going to pass it to our IT people who have access to the installation.
Best
David
The administrator has disabled public write access.

XOT objects not displaying in Safari 3 years 8 months ago #2176

  • Ron Mitchell
  • Ron Mitchell's Avatar
  • Offline
  • Administrator
  • Posts: 416
  • Thank you received: 101
Ok the files that need fixing are as follows:
\modules\site\play.php
\modules\site\preview.php
\modules\xerte\player_html5\rloObject.htm

The change needed is to change
<script type="text/javascript" src="c328740.ssl.cf1.rackcdn.com/mathjax/late...ML-AM_HTMLorMML-full"></script>

to

<script type="text/javascript"
src="//cdn.mathjax.org/mathjax/latest/MathJax.js?config=TeX-AMS-MML_HTMLorMML">
</script>

This has already been fixed in the xerte code repository (by Tom Reijnders) but obviously requires someone to apply those changes to your install.

HTH
Ron
e-learning & m-learning consultant
mitchellmedia.co.uk
xerteacademy.com
learningapps.co.uk
The administrator has disabled public write access.
The following user(s) said Thank You: Paul Vaughan

XOT objects not displaying in Safari 3 years 8 months ago #2177

  • David Perkins de Oliveira
  • David Perkins de Oliveira's Avatar
  • Offline
  • Junior Boarder
  • Posts: 26
Thanks. I'll pass this on.
The administrator has disabled public write access.

XOT objects not displaying in Safari 3 years 8 months ago #2199

  • David Perkins de Oliveira
  • David Perkins de Oliveira's Avatar
  • Offline
  • Junior Boarder
  • Posts: 26
Thanks, Ron. This seems to have done the trick.
Best
David
The administrator has disabled public write access.
  • Page:
  • 1
  • 2
Moderators: Alistair McNaught
Time to create page: 0.476 seconds
Powered by Kunena Forum